Willkommen, Gast
Angemeldet bleiben:

THEMA:

Joomla 3.10.1 updaten nach Joomla 4.0 02 Sep 2021 15:03 #49728

Ich habe jetzt meine ersten Webseiten mit Joomla 4 online. Sehrzufriedenbin!
Die erste Webseite habe ich neuinstalliert und die (wenigen) Inhalte mittels Copy&Paste «migriert».
Bei der zweiten Webseite habe ich mich an ein Update gewagt. Und siehe da: es hat recht gut funktioniert.
Ohne ein Joomla 4.0 kompatibles Template geht's natürlich nicht.
Also müssen wir uns entweder mit Cassiopeia zufriedengeben oder ein Joomla 4.0 kompatibles Template für die Installation bereithalten.
Hier meine Erfahrungen:
  • Subdomain erstellen
  • die produktive Webseite in diese Subdomain kopieren
  • Datenbank exportieren
  • eine neue Datenbank erstellen
  • die exportierte Datenbank in die neu erstellte, leere Datenbank importieren
  • die configuration.php, die sich in der Subdomain befindet, öffnen
  • die neuen Datenbankangaben (vier Zeilen) anpassen:
    public $host = 'xxx';
    public $db = 'xxx';
    public $user = 'xxx';
    public $password = 'xxx';
  • in die kopierte Webseite (in der Subdomain einloggen)
  • alle überflüssigen Inhalte löschen, auch aus dem Papierkorb (Beiträge, Kategorien, Menüeinträge, Module)
  • alle überflüssigen Erweiterungen deinstallieren
  • MENÜ Erweiterungen > Verwalten > Datenbank: prüfen ob ok,; wenn nötig [Reparieren]
  • MENÜ Erweiterungen > Verwalten > Aktualisieren: [Leeren] > [Updates suchen]; wenn nötig Updates installieren
  • MENÜ System > Globales Freigeben: wenn nötig alles markieren > [Freigeben]
  • MENÜ System > Cache leeren: [Alles löschen]
  • MENÜ Komponenten > Joomla Update > [Optionen] > Update-Server = Joomla! Next > [Speichern & Schliessen]
  • Installationsprüfung für Joomla 4.0.2 wird jetzt angezeigt (nicht gerade das Übersichtlichste das ich je gesehen habe). Die hier angezeigten Update-Empfehlungen und Hinweise auf allfällige Inkompatibilitäten beachten.
  • Reiter «Live Update»
  • [Update installieren]
Nach der erfolgreichen Instalation wird das neue Joomla 4.0 Back-End angezeigt.
Im Front-End wird man höchstwahrscheinlich eine Fehlermeldung vorfinden.
Diese ist auf das nicht Joomla 4.0 kompatible Template zurückzuführen.
Deshalb:
  • MENÜ System > Site Template Stile > Cassiopeia als Standard definieren
    oder
  • MENÜ System > Installieren > Erweiterungen ein Joomla 4.0 kompatibles Template installieren und dieses als Standard definieren
Nun dürfte im Front-End die Fehlermeldung verschwunden sein und zumindest irgendetwas halbwegs Vernünftiges angezeigt werden. Nun müssen noch die Modulpositionen ans neue Template angepasst werden.

Wenn alles getestet ist und funktioniert:
  • einen Unterordner OLD erstellen und die alte Webseite hineinverschieben
  • alle Dateien von der Subdomain an den Speicherort wie die alte Webseite war (zum Beispiel «public_html») verschieben
  • Browsercache löschen
  • Seite aktualisieren
  • Neue Webseite ist in Betrieb!
Folgende Benutzer bedankten sich: Tribal6, patrick, Dragonlord, MartinKopp

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1