Willkommen, Gast
Angemeldet bleiben:

THEMA:

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 12:35 #49164

Ich habe eine seltsame Erfahrung gemacht und möchte Euch fragen, was Ihr davon hält.

Ausgangslage
Ich habe eine Webseite mit einem älteren Template der Firma Crosstec.
Dieses basiert auf Gantry 4.1.43.
Nachdem ich mit PHP auf 7.4 gegangen war, gab's ein paar Fehlermeldungen auf der Webseite.
Daraus konnte man auf «Gantry» als Ursache schliessen.

Aktualisierung auf Gantry 5
Anstatt eine neue Version des Templates zu kaufen, kam ich auf die Idee, eigenhändig eine Aktualisierung auf Gantry 5 vorzunehmen.
  • Komplettes Backup der Webseite und der Datenbank erstellt
  • Gantry heruntergeladen und installiert (parallel zu Gantry 5, beide Versionen sind aktiviert)
  • Fehlermeldungen sind immer noch da :-(
  • Erweiterungen > Verwalten > alles was mit Gantry 4 angeschrieben ist deaktiviert
  • Fehlermeldungen sind weg :-)
  • Erweiterungen > Verwalten > alles was mit Gantry 4 angeschrieben ist deinstalliert
  • Webseite funktioniert gar nicht mehr, Fehlermeldung, dass Gantry nicht gefunden werden könne
  • Gantry 4 wieder installiert (parallel zu Gantry 5) aber deaktiviert
  • Webseite funktioniert wieder, Fehlermeldungen sind weg :-)
Bisher dachte ich, das Deaktivieren einer Erweiterung sei ein guter Funktionstest, bevor man sie deinstalliert.
Doch in diesem Fall scheint sie irgendwie doch noch eine Rolle zu spielen, obwohl sie deaktiviert ist.
Das verstehe ich jetzt nicht wirklich.
Hat jemand eine plausible Erklärung dafür?

Vielen Dank und Gruss
Christof
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 12:47 #49165

Was sagen denn die Fehlermeldungen?
Ev. muss noch ein (älteres) Plugin dazu deaktiviert werden, das noch versucht das alte Template aufzurufen.

Denn eben, Fehlermeldungen sagen einem normalerweise, was das Problem ist - und meist auch wo es auftritt.
(wenn es denn PHP-Fehlermeldungen sind -> Fehleranzeige auf Maximum in der glob. Konf.)
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 12:49 #49166

Vorallem diese hier:

Webseite funktioniert gar nicht mehr, Fehlermeldung, dass Gantry nicht gefunden werden könne

Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 14:44 #49167

Warning: Creating default object from empty value in /home/httpd/vhosts/xxxxxxxxxxxxxx.ch/httpdocs/plugins/system/gantry/overrides/3.3/2.5/com_content/category/default_articles.php on line 17

 

This template requieres the Gantry Template Framework. Please download and install from www.gantry-framework.org/download

Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 15:10 #49168

Hmm....der Fehler wird im Code abgefangen. Und mit hochdrehen der Fehleranzeige gibt's auch keine PHP-Fehlermeldung?

Im Netz findet sich nicht viel gscheites, nur das hier:
rockettheme.com/forum/gantry-solved-thre...ith-gantry-5-install
(nach ein paar Mal In- und Deinstallieren hat's dann mal geklappt!)

Müsste ich diesen Fehler beheben, würde ich die komplette Seite mal runterladen, und in den Files nach dieser Fehlermeldung suchen, resp. die Stelle, wo sie 'geworfen' wird.

Aber sonst kann ich hier nicht viel weiterhelfen. Vielleicht hat ja sonst noch jemand eine Idee

LG
R
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 15:18 #49169

Das Problem ist ja eigentlich gelöst, die Fehlermeldung verschwunden.
Mich wundert es einfach, dass die Webseite gar nicht mehr funktioniert, wenn Gantry 4 deinstalliert ist.
Fehlermeldung «This template requieres the Gantry Template Framework.»

Wenn Gantry 4 installiert ist, aber deaktiviert, dann funktioniert sie.
Die Frage ist «Wie kann eine deaktivierte Erweiterung funktionieren?»
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Gantry 4 bzw. 5 für Crosstec Templates 12 Mär 2021 16:21 #49170

Wenn die Files von z.B. Plugin, Library, Komponente da sind, sind sie auch direkt via Filesystem 'erreichbar'. Egal ob sie nun aktviert sind oder nicht.

Ob aktiviert oder deaktiviert ist lediglich eine DB-Abfrage/Zwischenschicht dazwischen, die aber nicht immer abgefragt wird: direkt übsers Filesystem z.B. nicht - im Backend aber oder z.B. beim Seitenaufbau (welche Extensions sind aktiviert) hingegen schon.

Und nach der Deinstallation sind die Files dann auch physikalisch weg, also auch direkt übers Dateisystem nicht mehr erreichbar.

Ich denke in Gantry4 sind Files oder Funktionen drinnen, die benötigt werden - weil eben ev. die Gantry5-Installation nicht vollständig war, so wie in dem geposteten Forums-Thread beschrieben.
(und in Gantry4 sind diese fehlenden Files anscheinend aber auch enthalten = es funktioniert dann auch mit installiertem G4)
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...
Folgende Benutzer bedankten sich: RePao, crimle

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1