Willkommen, Gast
Angemeldet bleiben:

THEMA:

Email senden geht nicht 23 Apr 2021 00:06 #49337

Nach dem Umzug meiner Site zu einem neuen Hoster kann ich keine Emails mehr versenden.
Bei Joomla/Konfiguration/Server/Testmail erhalte ich folgende Fehlermeldung:
Beim Abrufen von JSON-Daten wurde ein HTTP-Fehler-Code 500 zurückgegeben. Internal Server Error.
Mit einem einfachen PHP-Script funktioniert es allerdings.
Weiss jemand Rat dazu?
Joomla 3.9.62, PHP 7.4.16

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 07:26 #49338

Wie lautet denn die Einstellung «Mailer» bei Konfiguration > Server?
Hast Du da «PHP-Mail» oder «Sendmail» oder «SMTP»?

 
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 07:35 #49339

Dankeschön, auch dir ein 'Hallo'.

Also ich kenne diesen Fehler nicht. Du müsstest dazu das Script
media/system/js/sendtestmail.js
debuggen, um die Ursache herauszufinden.

Wichtiger aber wäre wohl die Frage, ob nur die Testmail-Funktion fehlerhaft ist. Kommen denn z.B. 'Neuen Benutzeraccount erstellt'-Mails an?

Tipp: Fehlermeldungen kann man auch ganz gut googeln. Wenn ich z.B. nach 'joomla Beim Abrufen von JSON-Daten wurde ein HTTP-Fehler-Code' suche, sehe ich da schon ein paar Resultate. In einem war z.B. die Verwendung des Servermoduls 'mod_security' die Ursache.
Und ironischerweise kam die Antwort von diesem Forum.
Tu das was du kannst, mit dem was du hast, da wo du bist
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 08:43 #49340

Dankeschön, auch dir ein 'Hallo'.
 

Hallo Roger
Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 09:20 #49341

Sali Chris
Ist doch wahr, oder nicht? Nenn es freundlich, höflich oder old-school...
Tu das was du kannst, mit dem was du hast, da wo du bist
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 09:38 #49342

Der Mailserver ist auf PHP eingestellt
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 09:44 #49343

Wichtiger aber wäre wohl die Frage, ob nur die Testmail-Funktion fehlerhaft ist. Kommen denn z.B. 'Neuen Benutzeraccount erstellt'-Mails an?

Tu das was du kannst, mit dem was du hast, da wo du bist
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 09:45 #49344

Ich habe in der Website Formulare mit Breezingsform erstellt, die gehen leider auch nicht.
Log_error zeigt mir folgenden Text an:
Notice: Trying to access array offset on value of type int in /..../wtclean-pro/Warp/Config/Repository.php on line 243
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 10:00 #49345

Ist schwierig 'von hier aus' zu sagen.
Stell doch mal auf die 'SMTP'-Methode um in der glob. Konfiguration, mit direktem Versand ab einem existierenden Mailkonto (idealerweise mit derselben Domain wie die Seite, wegen Spamfiltern)
Ich denke "Nach dem Umzug meiner Site zu einem neuen Hoster" ist der entscheidende Hinweis....da gibt es offenbar Unterschiede der beiden Hostings, wenn das vorher funktioniert hat.

Und die PHP-Notice ist eigentlich nicht so schlimm...zumal sie offenbar vom Template kommt.
 
Tu das was du kannst, mit dem was du hast, da wo du bist
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Email senden geht nicht 23 Apr 2021 10:24 #49346

Ich habe es mit neuem Benutzeraccount, mit SMTP und Sendmail versucht, es erscheint immer die Fehlermelung.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2