Willkommen, Gast
Angemeldet bleiben:

THEMA:

Ein übler Bug? oder doch nicht? 09 Apr 2021 19:48 #49246

Ich diese Woche auf etwas gestossen, was in diesem Artikel beschrieben wird:

onlinecommunityhub.nl/best-practice/why-...-you-can-do-about-it

Das Funktionieren des Bugs wird im Artikel demonstriert.
Kurz das hier findet man auf Google:
www.joomla.org/announcements/release-new...uld-never-use-joomla
(auf der 2. Seite wen man auf Google 'Joomla is bad for SEO' eingibt)
Die Url kann man nach dem 5834- beliebig variieren und alle mögliche Schandworte reinschreiben und in einem Artikel publizieren, der dann bei Google gefunden  wird, natürlich auch weil Joomla.org eine sehr respektable Seite ist.

Ich persönlich halte das für sehr bedenklich und es wird in Joomla 3.9 sicher nicht gefixt (bei Joomla 4.0 ist der Bug möglicherweise auch noch drin, falls die ID in der URL ist, da bin ich mir nicht sicher) - ich hoffe, nur das spricht sich nicht herum in den falschen Kreisen...

Eine Lösung ist die Entfernung der IDs aus der URL.
Zu setzen in Beiträge, Optionen, Integration (2-letzter Tab von rechts), Routing, IDs aus den URLs entfernen (kann man nur setzen wenn man auf dem 'Modern' Router ist).

Ich habe deshalb angefangen, wie im Artikel empfohlen, bei meinen Seiten die ID in den URLS abzuschalten.
Bei einer grossen Seite mit vielen Beiträge ist das nicht ganz einfach, weil:
Falls ein Alias eines Beitrags doppelt ist, dann funktioniert der Link nicht mehr -> es kommt eine 404 Seite.

D.h. durch den Fix funktioniert die Seite u.U. nicht mehr korrekt! Also Vorsicht.

Hier ein SQL-Statement, wie ich solche Beitrage zumindest aufliste (in PHPAdmin auf eurer Joomla-DB)
SELECT id,alias FROM zw1pt_content WHERE alias IN (SELECT alias FROM zw1pt_content GROUP BY alias HAVING COUNT(*)>1) ORDER BY alias,id desc
zw1pt müsst ihr natürlich durch euren eigenen Table-Prefix ersetzen.

Ich hoffe, geholfen zu haben.

 
Folgende Benutzer bedankten sich: RePao, King Louis

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ein übler Bug? oder doch nicht? 10 Apr 2021 08:56 #49247

Das Problem ist seit längerer Zeit bekannt, es wurde hier schon beschrieben [siehe Post #10]. Offenbar interessiert sich bei den Entwicklern niemand so richtig für dieses Thema, da es offenbar in J!4 immer noch akut ist. Eine mögliche Lösung wird in o.g. Beitrag in #12 genannt (hab ich aber nie ausprobiert). Das mit den Pornoseiten ist allerdings hässlich, ich denke, da muss dringend was gemacht werden.
Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Folgende Benutzer bedankten sich: RePao, King Louis, MartinKopp

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ein übler Bug? oder doch nicht? 10 Apr 2021 10:45 #49248

Leider muss ich noch anfügen, dass das Ausschalten der ID nicht hilft...
Es werden zwar jetzt keine ID's mehr generiert, trotzdem funktionieren die "alten" URLS noch und das heisst auch, dass die missbräuchlichen Links auf Google oder anderen Webseiten  noch funktionieren.
Gerade für SEO führt dies offenbar leicht zur Abwertung von Seiten, da Google auch die URL mit zur Bewertung benützt. Google bewertet, ob der Inhalt der Url etwas zu tun hat mit dem Inhalt der Webseite. Der Inhalt von www.joomla.org/announcements/release-new...uld-never-use-joomla hat nichts mit der URL zu tun, deshalb schätze ich, dass sowohl die Seite die diesen Link postet, als auch die Seite selbst spürbar abgewertet werden. Das würde nicht passieren, wenn die URL eine 404 Seite gibt - dann würde Google die Seite mit dem falschen Link (er führt ja zu 404) abstrafen und könnte den Inhalt der Zielseite ja gar nicht überprüfen.
Folgende Benutzer bedankten sich: RePao

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1