Willkommen, Gast
Angemeldet bleiben:

THEMA:

Re: Suchmaschinenoptimierung 17 Feb 2009 13:41 #20803

  • Autor
  • PSH.ch
  • Besucher
  • Besucher
@jimbo

Damit unsere Seiten auch erreichbar bleiben, habe ich im Backend bei SEO nicht alles auf "Ja" gesetzt, resp. nachdem ich festgestellt habe, dass die Seiten nicht mehr angezeigt werden (können), alles wieder zurück gesetzt. Sonst komm ich nicht mehr drauf. Wie bereits geschrieben habe ich die htaccess.txt im Root bereits auf .htaccess umbenannt. Weshalb es nun trotzdem nicht funzt ist mir nicht klar...

Gruss Harri

bez. <!-- l <a class="postlink-local" href="forum.joomla.ch/viewtopic.php?f=10&t=2825">viewtopic.php?f=10&t=2825
  • PSH.ch
  • Besucher
  • Besucher
  • Also ich hab's jetzt nochmals umgestellt auf alles "Ja". Und es kommt zum 404 Fehler, dass die Seiten nicht gefunden werden können. Hab doch auch da und dort gelesen, dass die eine oder andere Zeile in der .htaccess angepasst werden kann. Ev. Hilft's ja. Aber wo genau? jimbo - Du hast da doch was auf Deiner Seite erläutert gehabt. Hast Du mir da nen Tipp?

    jimbo schrieb: Kann ich bestätigen, habe ebenfalls mehrere Seiten bei Hostpoint und die laufen (inkl. SEO) einwandfrei.

    Wenn die Options +FollowSymLinks stören führt das übrigens zu einem Error500, 404 bedeutet dass die Seite/Datei nicht gefunden wird. Bei Hostpoint ist es aber richtig diese auszukommentieren, die Server dort vertragen diese "Options" nicht. ;)

    PSH.ch schrieb: ... Mod_rewrite ist aktiviert. Die htaccess heisst bei mir .htaccess. So wie es meines Wissens nach sein müsste. Muss ich denn jetzt bei der Verlinkung unserer Seiten die Links neu setzen? --ALTER LINK WURDE ENTFERNT-- ...


    Ähm – auf dieser Seite ist SEO überhaupt nicht aktiviert... Zuerst gehst Du ins Joomla-Backend und setzt dort in der Konfiguration unter SEO alle 3 Einträge auf JA, dann änderst Du die htaccess.txt im Joomla-Root auf .htaccess und damit sollte es erledigt sein. Joomla erkennt die alten "unfreundlichen" Links und wandelt sie "live" um, es muss nichts geändert werden.


    Werde jetzt wieder zurück schalten auf die "unfreundlichen" Links... :(
    Unsere Site muss erreichbar bleiben...

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 17 Feb 2009 20:43 #20812

    Nein, keinen Tipp ausser dem bereits genannten. Ich würde als erstes einmal bei hoststar anklopfen, ob die mod_rewrite überhaupt unterstützen. Auf Grund der von Dir beschrieben Verhaltensweise würde ich darauf tippen, dass dies nicht der Fall ist. Wenn Du einmal hier im Board nach hoststar suchst, wirst Du auch schnell feststellen, dass dieser Hoster nicht die besten Voraussetzungen für ein fehlerfrei laufendes Joomla bietet (ausser die hätten ihre ganze Serverkonfigs geändert).

    Fällt mir noch ein: Wenn Dein Joomla nicht im Root sondern in einem Unterverzeichnis liegt, kann es nötig sein, dass Du RewriteBase entsprechend anpasst. Alles in allem kann Dir da aber vermutlich nur der Hoster weiterhelfen, die Einstellungen in der htaccess hängen sehr stark mit der Serverkonfiguration zusammen und die kennt nur der Hoster selber. Ist zwar für 1.0.x aber sollte in den Grundsätzen immer noch passen: --ALTER LINK WURDE ENTFERNT--

    ...und wenn Du SEO nicht aktiviert lassen kannst, wird die Hilfe auch nicht wirklich leichter, denn man kann sich nicht ansehen, was da überhaupt für Code/Links generiert werden. ;)
    Gruss Dany (Jimbo)
    Kein Support per PN.

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 18 Feb 2009 08:43 #20820

    • Autor
    • PSH.ch
    • Besucher
    • Besucher
    Hoi Jimbo

    Danke nochmals für den Hinweis. Die diversen Meldungen hier im Forum zu Hoststar habe ich gesehen. Und ich habe Hoststar bereits kontaktiert. Mal abwarten was die zurück schreiben. Deine Tipps zur htaccess auf Deiner Webseite habe ich gestern schon mal durchgesehen. Je nach Feedback von Hoststar werde ich mal prüfen, ob ich da drinn was anpassen kann.

    Gruss
    Harri

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 18 Feb 2009 09:11 #20821

    • gold
    • Besucher
    • Besucher

    webuniverse schrieb: hallo

    mit Hostpoint gehts sicher, habe auch seiten dort....

    ich habe in der .htaccess folgende Zeile auskommentiert (#)

    Options +FollowSymLinks

    So:
    # Options +FollowSymLinks

    Gruss Corinne


    Danke für den Tipp, bevor ich das hier gesehen habe, hab ich den Support von Hostpoint genervt:)(der ja eigentlich kein support von joomla macht) der Typ war nicht gerade freundlich, aber dennoch korrekt und trotzdem cool, den heute funktioniert es, in der .htaccess wollte ichs ändern, scheinbar hat er es schon geändert?
    Da steht:

    The line just below this section: 'Options +FollowSymLinks' may cause problems
    # with some server configurations. It is required for use of mod_rewrite, but may already
    # be set by your server administrator in a way that dissallows changing it in
    # your .htaccess file. If using it causes your server to error out, comment it out (add # to
    # beginning of line), reload your site in your browser and test your sef url's. If they work,
    # it has been set by your server administrator and you do not need it set here.

    ## Can be commented out if causes errors, see notes above.
    #Options

    #
    # mod_rewrite in use

    RewriteEngine On

    das hier war nicht mehr vorhanden: "Options +FollowSymLinks" nur noch die Options..
    Wie auch immer, es geht jetzt:) Komischer weise wurde der news Beitrag von mir, durch einen von joomla ersetzt, keine Ahnung..

    Ev. hilft das auch jemandem wieder weiter?
    Gruss

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 18 Feb 2009 14:06 #20827

    • Autor
    • PSH.ch
    • Besucher
    • Besucher
    Also. Ich habe nun ein Feedback von Hoststar erhalten. Die sind dort wirklich fix und hilfsbereit. Das muss man den Leuten von Hoststar lassen. Ich habe bisher immer gute Erfahrungen gemacht. Nun denn. Folgendes wurde von Hoststar gemacht.

    Die mod_rewrite Option wurde bei den Apache Einstellungen aktiviert.

    Zusätzlich wurde PHP5 aktiviert in der .htaccess welche momentan aktiv ist.

    Ich habe eben die Einstellung nochmals vorgenommen und es funzt jetzt. Also an alle, die Hoststar als Provider haben. Schreibt denen und das Problem wird gelöst. :) ) ) ) ) ) D D D D D D

    Gruss Harri

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 18 Feb 2009 19:28 #20830

    PSH.ch schrieb: ... Die mod_rewrite Option wurde bei den Apache Einstellungen aktiviert. ...

    Diese Funktion sollte eigentlich standardmässig aktiviert sein, haben die irgendwas gesagt, warum sie die deaktivieren? *kopfschüttel*
    Gruss Dany (Jimbo)
    Kein Support per PN.

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 20 Feb 2009 09:06 #20837

    • Autor
    • PSH.ch
    • Besucher
    • Besucher
    Nöö haben sie nicht. Ich denke die haben gewisse Dinge standardmässig ausgeschaltet und schalten die erst auf Anfragen ein. Anders kann ich es mir auch nicht erklären. Ob man sowas nachvollziehen kann oder nicht bleibt dann wohl jedem selber überlassen ;) 8) .

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    Re: Suchmaschinenoptimierung 05 Feb 2013 19:54 #36031

    Was heißt aktiviert. Aktivieren tut man das eigentlich mit der .htaccess mit RewriteEngine On
    Das Modul wird vermutlich nicht installiert gewesen sein. Eigentlich Standard. Hauptsache es funktioniert jetzt.

    Bitte Anmelden oder Registrieren um der Konversation beizutreten.

    • Seite:
    • 1
    • 2