Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Editor im Frontend - z-index problem

Editor im Frontend - z-index problem 25 Jan 2012 11:50 #33990

  • zeebee
  • zeebees Avatar Autor
  • Besucher
  • Besucher
Hallo zusammen.
[Bin Anfängerin, learning by doing and readingHoch2 :), benutze joomla 1.73; neuster JCE; und mein erstes selber erstelltes Template für unseren Verein]

Ausgangslage: Die Hintergrundgrafik ist hoch, d.h ich wollte per z-index die Zugänglichkeiten (Logo-Link; Sprachwechsel; Breadcrumbs; Navigation; Drucksymbole) einstellen, was ich nach Üben/Lesen/Ausprobieren auch hingekriegt habe.
Probleme:
1a) Wenn ich nun den Beiträgen auch einen z-index verpasse, was Sinn macht, weil dort z.b. Formularfelder oder Links anwählbar sein müssen. Dann funktioniert die Navigation nicht mehr richtig, obwohl in der navigations-css der z-index höher ist also eigentlich über dem artikel zu liegen kommt. Und mit nicht richtig funktionieren meine ich, dass das Untermenu zwar sichtbar wird, aber nur bis auf die Höhe vom Content funktionsfähig ist, fahre ich mit der Maus zu so einem Unterpunkt, der in den Content ragt, schliesst sich das Menu - Untermenupunkte oberhalb Content sind jedoch anwählbar.
1b) Der Editor funktioniert so im Frontend nicht (Liegt auch quasi hinter etwas), will heissen er öffnet sich und ich kann ab Ende der Hintergrundgrafik auch editieren, aber alles was darüber ist hat keine Funktion.
2.) Derzeitiger Stand online: Wenn ich den Beiträgen keinen z-index zuweise, funktioniert die Navigation perfekt. Editor ist startbar, speichern etc. nicht möglich; wie oben.
3.) Habe lokal diverses ausprobiert. Den Editor hatte ich schon mal soweit, dass ich wenigstens abbrechen konnte, aber speichern hat nie funktioniert. Dafür war das oben beschriebene Navigationsproblem vorhanden.
Langer Rede kurzer Sinn: Weiss jemand Rat? (Bei JCE meinen sie nur, dass das ein Joomla oder Templateproblem sei) Wäre ja gut möglich, bei meinen Kenntnissen. Habe mir viele Nächte und Tage um die Ohren geschlagen und wäre sehr Dankbar um Hilfe. (P.S. Hatte die Hintergrundgrafik ursprünglich zweigeteilt, brachte es aber nicht hin, die beiden Teile nahtlos in allen Browsern zu positionieren. Damals las ich in einem JoomlaForumThread den Rat an jemand anderen, eine daraus zu machen - war wohl ein Fehler?).
Herzlichen Dank schon mal und Gruss!

Link zur temporären Online-Site

Falls ein Moderator Zugang braucht, kann ich gerne temporäre Zugangsdaten zustellen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von zeebee. Begründung: Ergänzung:

Aw: Editor im Frontend - z-index problem 25 Jan 2012 23:08 #33997

Hi

z-index Anweisungen sind normalerweise nur bei sich überlappenden Elementen nötig. Und die kommen meist in JavaScript-Dingen wie ausklappbare Menus, Image-Sliders u.ä. vor. Ansonsten braucht es in einem 'normalen' Template eigentlich keine z-index Anweisungen. Denn wenn du damit erst mal anfängst....du siehst ja den Schlamassel bei dir...;)

Ohne z-index Anweisung haben alle Elemente per Default
z-index: auto;
Angezeigt und die eben 'automatischen' Z-Indexe bekommen sie in der Reihenfolge wie sie im Quelltext von oben nach unten erscheinen. Und da Kind-Elemente im Quelltext ja nach dem Elternelement stehen, werden sie auch über dem Elternelement angezeigt.

Du müsstest also im Prinzip nur dem richtigen (Eltern-)Element das Hintergrundbild zuweisen, mehr nicht. Und in deinem Fall wäre das vermutlich
#container
im template.css zeile 146
(war einbisschen schwierig das im Firebug nachzuvollziehen, da dieses CSS zweimal includet wird)

Ich hab kurz nachgeschaut, es gibt im Netz einige Tutorials, die die Sache mit dem z-index erklären. Würd ich mal gucken. Und ev. den einen oder anderen experimentellen Versuch machen.

Ich selber mache keine Templates, und bin auch weit davon entfernt, ein CSS-Experte zu sein. Deshalb möge man mich auch bitte korrigieren, falls ich Quatsch verzapft habe.

Nächtle
Roger
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...
Folgende Benutzer bedankten sich: zeebee

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: Editor im Frontend - z-index problem 26 Jan 2012 03:13 #33998

  • zeebee
  • zeebees Avatar Autor
  • Besucher
  • Besucher
Ja genau: Nächtle! Lach.
Herzlichen Dank für deine Antwort. Gelesen und gelernt und experimentiert hab ich schon Nächtelang. Aber dein Vorschlag ist NEU - hoff, hoff! Den Versuch verschieb ich auf heute nach dem Schlaf - werde dann berichten.

Ooops, CSS wird 2 x included. Wie ich wohl das wieder geschafft hab!?
Da kommt die Anfängerin voll durch, was?
Dankes-Gruss
ZeeBee

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: Editor im Frontend - z-index problem 26 Jan 2012 20:51 #34017

Da kommt die Anfängerin voll durch, was?

Ja, genau. Na und?
Fehler machen und daraus lernen nennt man am Ende dann Erfahrung, und da muss jeder wohl oder übel durch.
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: Editor im Frontend - z-index problem 16 Feb 2012 14:47 #34172

  • zeebee
  • zeebees Avatar Autor
  • Besucher
  • Besucher
Also ein grosse Danke an Tribal6 - Absolut Bingo! Hatte ja vorab etliches gelesen zu den z-indexen, aber so einfach erklärt war es nirgends; oder es liegt eben auch hier wieder an einem konkreten Beispiel (bin keine Theoretikerin :) )

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: Editor im Frontend - z-index problem 16 Feb 2012 18:07 #34175

aberimmerwiedergernedoch ;)

And sänk ju matschi for se fidback.
Man soll das Kind ins Korn werfen solange es noch heiss ist, auch wenn das der eine Tropfen ist, der dem Fass die Krone ins Gesicht schlägt...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1