Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Mehrsprachig aber....

Mehrsprachig aber.... 14 Jun 2019 15:24 #46843

Hallo zusammen

Ich nutze Joomla nun schon seit Jahren und bin immer noch fan davon. Jetzt aber habe ich ein Problem, welches ich trotz nachlesen in den Foren nicht lösen kann.
Gemäss Multilinugal status sollte alles in ordnung sein. Wenn man aber auf
www.haller-net.ch geht welches auf die entsprechende Sprache umleitet /de oder /en etc.
Kann die Seite nicht dargestellt warden

Verwende ich index.html?lang=en oder lang=de
wird die Seite angezeigt.

Ist da noch etwas im .htaccess das nicht past? Oder sonst etwas was ich noch übersehen hab?

Danke und Gruess
Stefan
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehrsprachig aber.... 14 Jun 2019 18:25 #46844

Verwende ich index.html?lang=en oder lang=de

Klingt schwer nach Quatsch, das glaube ich nicht. Wenn schon sagt man index.php?

Bei mir läuft die Seite jedenfalls überhaupt nicht. Meines Erachten handelt sich das um eine fehlarhaft .htaccess Datei. Knipse die mal aus und schalte im Backend 'URL Rewrite nutzen' mal aus.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.

Mehrsprachig aber.... 14 Jun 2019 20:27 #46845

Hallo Chris

Danke für die nette Antwort :)
Ich habe's in der Eile falsch eingetippt. Also nochmal:

www.haller-net.ch/index.php?lang=de
www.haller-net.ch/index.php?lang=en
www.haller-net.ch/index.php?lang=ru

funktioniert.

----
ohne URL rewrite wird entsprechend:
www.haller-net.ch/index.php/de/
www.haller-net.ch/index.php/en/
www.haller-net.ch/index.php/ru/

verwendet

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehrsprachig aber.... 15 Jun 2019 07:24 #46846

OK, so macht es mehr Sinn.

Prüfe bitte folgendes:
Im Stammverzeichnis der Seite muss sich eine Datei namens .htaccess befinden, am Besten die umbenannte htaccess.txt, die Joomla mitliefert. In dieser Datei hat es eine Zeile, die heisst
## Mod_rewrite in use.
RewriteEngine On

Dann prüfst du im Backend unter der globalen Konfiguration im ersten Tab auf der rechten Seite, dass die Schalter so gestellt sind:

Wenn du über die Beschriftungen fährst, siehst du Erklärungen:


Ich gehe davon aus, dass du einen Apache Server hast, sollte es ein IIS sein, musst du die Anweisung bezüglich dem befolgen.
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Letzte Änderung: von Chris Hoefliger.

Mehrsprachig aber.... 16 Jun 2019 21:17 #46847

Hallo Chris

Soweit so klar. Die .htaccess liegt seit 2017 an dem Ort inklusive RewriteEngine On
Nur eben, es tut nicht so wie ich es erwarten würde.
Verwendete PHP Version ist übrigens 7.2.18...

Mich nervt das gewaltig, weil ich weiss, dass dies früher alles funktioniert hat.

Gruss
Stefan

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1